{"id":116038,"date":"2023-11-24T10:47:56","date_gmt":"2023-11-24T01:47:56","guid":{"rendered":"https:\/\/softantenna.com\/blog\/?p=116038"},"modified":"2023-11-24T10:47:56","modified_gmt":"2023-11-24T01:47:56","slug":"openssl-3-2","status":"publish","type":"post","link":"https:\/\/softantenna.com\/blog\/openssl-3-2\/","title":{"rendered":"OpenSSL 3.2\u304c\u30ea\u30ea\u30fc\u30b9 - \u30af\u30e9\u30a4\u30a2\u30f3\u30c8\u30b5\u30a4\u30c9\u306eQUIC\u30b5\u30dd\u30fc\u30c8\u3084\u3001\u30c7\u30d5\u30a9\u30eb\u30c8\u306eSSL\/TLS\u30bb\u30ad\u30e5\u30ea\u30c6\u30a3\u30ec\u30d9\u30eb\u304c1\u304b\u30892\u3078"},"content":{"rendered":"<p><img decoding=\"async\" style=\"display:block; margin-left:auto; margin-right:auto;\" src=\"https:\/\/softantenna.com\/blog\/wp-content\/uploads\/2023\/11\/s_20231124_103507.jpg\" alt=\"S 20231124 103507\" title=\"s_20231124_103507.jpg\" border=\"0\" width=\"860\" height=\"560\" \/><\/p>\n<p>OpenSSL\u958b\u767a\u30c1\u30fc\u30e0\u306f11\u670823\u65e5(\u73fe\u5730\u6642\u9593)\u3001\u300cOpenSSL 3.2.0\u300d\u3092\u30ea\u30ea\u30fc\u30b9\u3057\u307e\u3057\u305f(<a href=\"https:\/\/www.openssl.org\/blog\/blog\/2023\/11\/23\/OpenSSL32\/\">OpenSSL Blog<\/a>)\u3002OpenSSL 3.2.0\u306fOpenSSL 3.2\u30ea\u30ea\u30fc\u30b9\u30e9\u30a4\u30f3\u306e\u6700\u521d\u306e\u4e00\u822c\u63d0\u4f9b\u30ea\u30ea\u30fc\u30b9\u3067\u3001\u591a\u6570\u306e\u65b0\u6a5f\u80fd\u304c\u7d44\u307f\u8fbc\u307e\u308c\u3066\u3044\u307e\u3059\u3002<\/p>\n<p>\u307e\u305a\u3001\u30de\u30eb\u30c1\u30b9\u30c8\u30ea\u30fc\u30e0\u306e\u30b5\u30dd\u30fc\u30c8\u3092\u542b\u3080\u3001\u30af\u30e9\u30a4\u30a2\u30f3\u30c8\u30b5\u30a4\u30c9QUIC\u306e\u30b5\u30dd\u30fc\u30c8\u304c\u884c\u308f\u308c\u307e\u3057\u305f\u3002QUIC\u306fGoogle\u306b\u3088\u3063\u3066\u958b\u767a\u3055\u308c\u3001IETF\u306b\u3088\u3063\u3066\u63a1\u7528\u3055\u308c\u305f\u6c4e\u7528\u30c8\u30e9\u30f3\u30b9\u30dd\u30fc\u30c8\u5c64\u30cd\u30c3\u30c8\u30ef\u30fc\u30af\u30d7\u30ed\u30c8\u30b3\u30eb\u3067\u3059\u3002OpenSSL 3.2\u3067\u306f\u30af\u30e9\u30a4\u30a2\u30f3\u30c8\u30b5\u30a4\u30c9\u306e\u30b5\u30dd\u30fc\u30c8\u306e\u307f\u304c\u884c\u308f\u308c\u3001OpenSSL 3.3\u304b\u30893.4\u3067QUIC\u306e\u5b9f\u88c5\u304c\u3055\u3089\u306b\u9032\u3081\u3089\u308c\u308b\u4e88\u5b9a\u3067\u3059\u3002<\/p>\n<p>\u30c7\u30d5\u30a9\u30eb\u30c8\u306eSSL\/TLS\u30bb\u30ad\u30e5\u30ea\u30c6\u30a3\u30ec\u30d9\u30eb\u306e1\u304b\u30892\u3078\u306e\u5f15\u304d\u4e0a\u3052\u3084\u3001Ed25519ctx\u3001Ed25519ph\u3001Ed448p\u306e\u30b5\u30dd\u30fc\u30c8\u3001Linux\u3001macOS\u3001FreeBSD\u306b\u304a\u3051\u308bTCP Fast Open\u306e\u30b5\u30dd\u30fc\u30c8\u3082\u884c\u308f\u308c\u3066\u3044\u307e\u3059\u3002Windows\u3067\u306f\u4fe1\u983c\u3055\u308c\u305f\u30eb\u30fc\u30c8\u8a3c\u660e\u66f8\u306e\u30bd\u30fc\u30b9\u3068\u3057\u3066Windows\u30b7\u30b9\u30c6\u30e0\u8a3c\u660e\u66f8\u30b9\u30c8\u30a2\u306e\u4f7f\u7528\u3092\u30b5\u30dd\u30fc\u30c8\u3057\u307e\u3057\u305f\u304c\u3001\u3053\u308c\u306f\u30c7\u30d5\u30a9\u30eb\u30c8\u3067\u6709\u52b9\u306b\u306a\u3063\u3066\u304a\u3089\u305a\u3001\u74b0\u5883\u5909\u6570\u3092\u4f7f\u7528\u3057\u3066\u6709\u52b9\u306b\u3059\u308b\u5fc5\u8981\u304c\u3042\u308a\u307e\u3059(\u5c06\u6765\u306e\u30ea\u30ea\u30fc\u30b9\u3067\u30c7\u30d5\u30a9\u30eb\u30c8\u3067\u6709\u52b9\u306b\u306a\u308b\u53ef\u80fd\u6027\u304c\u9ad8\u3044)\u3002<\/p>\n<p>\u65b0\u6a5f\u80fd\u306e\u30cf\u30a4\u30e9\u30a4\u30c8\u306f\u4ee5\u4e0b\u306e\u901a\u308a\u3067\u3059\u3002<\/p>\n<blockquote>\n<ul>\n<li>lient-side QUIC support, including support for multiple streams (RFC 9000)<\/li>\n<li>Certificate compression in TLS (RFC 8879), including support for zlib, zstd and Brotli<\/li>\n<li>Deterministic ECDSA (RFC 6979)<\/li>\n<li>Support for Ed25519ctx, Ed25519ph and Ed448ph (RFC 8032) in addition to existing support for Ed25519 and Ed448<\/li>\n<li>AES-GCM-SIV (RFC 8452)<\/li>\n<li>Argon2 (RFC 9106) and supporting thread pool functionality<\/li>\n<li>HPKE (RFC 9180)<\/li>\n<li>The ability to use raw public keys in TLS (RFC 7250)<\/li>\n<li>TCP Fast Open (RFC 7413) support, where supported by the OS<\/li>\n<li>Support for provider-based pluggable signature schemes in TLS, enabling third-party post-quantum and other algorithm providers to use those algorithms with TLS<\/li>\n<li>Support for Brainpool curves in TLS 1.3<\/li>\n<li>SM4-XTS<\/li>\n<li>Support for using the Windows system certificate store as a source of trusted root certificates. This is not yet enabled by default and must be activated using an environment variable. This is likely to become enabled by default in a future feature release.<\/li>\n<\/ul>\n<\/blockquote>\n<p>\u65b0\u6a5f\u80fd\u306e\u8a73\u7d30\u3084\u30c0\u30a6\u30f3\u30ed\u30fc\u30c9\u306f<a href=\"https:\/\/www.openssl.org\/blog\/blog\/2023\/11\/23\/OpenSSL32\/\">\u3053\u3061\u3089<\/a>\u304b\u3089\u53ef\u80fd\u3067\u3059\u3002<\/p>\n<p>[via <a href=\"https:\/\/www.phoronix.com\/news\/OpenSSL-3.2-Released\">Phoronix<\/a>]<\/p>\n","protected":false},"excerpt":{"rendered":"<p>OpenSSL\u958b\u767a\u30c1\u30fc\u30e0\u306f11\u670823\u65e5(\u73fe\u5730\u6642\u9593)\u3001\u300cOpenSSL 3.2.0\u300d\u3092\u30ea\u30ea\u30fc\u30b9\u3057\u307e\u3057\u305f(OpenSSL Blog)\u3002OpenSSL 3.2.0\u306fOpenSSL 3.2\u30ea\u30ea\u30fc\u30b9\u30e9\u30a4\u30f3\u306e\u6700\u521d\u306e\u4e00\u822c\u63d0\u4f9b\u30ea\u30ea\u30fc\u30b9\u3067 [&hellip;]<\/p>\n","protected":false},"author":2,"featured_media":116039,"comment_status":"open","ping_status":"closed","sticky":false,"template":"","format":"standard","meta":{"swell_btn_cv_data":"","footnotes":""},"categories":[75],"tags":[4404],"class_list":["post-116038","post","type-post","status-publish","format-standard","has-post-thumbnail","hentry","category-software","tag-openssl"],"_links":{"self":[{"href":"https:\/\/softantenna.com\/blog\/wp-json\/wp\/v2\/posts\/116038","targetHints":{"allow":["GET"]}}],"collection":[{"href":"https:\/\/softantenna.com\/blog\/wp-json\/wp\/v2\/posts"}],"about":[{"href":"https:\/\/softantenna.com\/blog\/wp-json\/wp\/v2\/types\/post"}],"author":[{"embeddable":true,"href":"https:\/\/softantenna.com\/blog\/wp-json\/wp\/v2\/users\/2"}],"replies":[{"embeddable":true,"href":"https:\/\/softantenna.com\/blog\/wp-json\/wp\/v2\/comments?post=116038"}],"version-history":[{"count":0,"href":"https:\/\/softantenna.com\/blog\/wp-json\/wp\/v2\/posts\/116038\/revisions"}],"wp:featuredmedia":[{"embeddable":true,"href":"https:\/\/softantenna.com\/blog\/wp-json\/wp\/v2\/media\/116039"}],"wp:attachment":[{"href":"https:\/\/softantenna.com\/blog\/wp-json\/wp\/v2\/media?parent=116038"}],"wp:term":[{"taxonomy":"category","embeddable":true,"href":"https:\/\/softantenna.com\/blog\/wp-json\/wp\/v2\/categories?post=116038"},{"taxonomy":"post_tag","embeddable":true,"href":"https:\/\/softantenna.com\/blog\/wp-json\/wp\/v2\/tags?post=116038"}],"curies":[{"name":"wp","href":"https:\/\/api.w.org\/{rel}","templated":true}]}}