Let's Encryptの証明書の期限切れにより一部のMacやAndroidがWebサイトに接続できない問題が発生中

  • URLをコピーしました!

S 20211002 203830
一部の古いMacやAndroidデバイスでブラウザからWebサイトに接続できない問題が発生していることがわかりました(gHacks)。

例えば、問題が発生したMacでは「NET::ERR_CERT_DATE_INVALID」というエラーコードとともに「この接続ではプライバシーが保護されません」というエラーメッセージが表示されます。

この問題は、Let's Encryptのルート証明書の有効期限が2021年9月30日までとなっていること原因で、期限切れのルート証明書を利用して発行された証明書は、クライアントからの信頼を得ることができずエラーが発生します。Let's Encryptは、2024年9月30日まで有効な新しい相互署名付きルート証明書によって、ルート証明書の期限切れによって発生する問題を軽減しようとしていますが、全ての場合で有効ではない模様です。

Let's Encryptは、2021年9月30日以降に問題が発生する可能性のあるプラットフォームと、そうでないプラットフォームのリストを公開しています。主に古いバージョンのmacOSやiOS、古いLinuxディストリビューション、Android 2.3.6以前のAndroid端末などが影響を受けるとのことです。

互換性があるプラットフォーム:

  • Mozilla Firefox >= v2.0
  • Google Chrome
  • Windows XP SP3 以降の Internet Explorer
  • Microsoft Edge
  • Android OS >= v2.3.6
  • macOS 上の Safari >= v4.0
  • Safari on iOS >= v3.1
  • Debian Linux >= v6
  • Ubuntu Linux >= v12.04
  • NSS Library >= v3.11.9
  • Amazon FireOS (Silk Browser)
  • Cyanogen > v10
  • Jolla Sailfish OS > v1.1.2.16
  • Kindle > v3.4.1
  • Java 7 >= 7u111
  • Java 8 >= 8u101
  • Blackberry >= 10.3.3
  • firmware >= 5.00 の PS4

互換性がないプラットフォーム:

  • Blackberry < v10.3.3
  • Android < v2.3.6
  • Nintendo 3DS
  • SP3 以前の Windows XP
    • SHA-2 の署名付き証明書が処理できない
  • Java 7 < 7u111
  • Java 8 < 8u101
  • Windows Live Mail (ウェブメールではなく、2012 メールクライアント)
    • CRL がない証明書が処理できない
  • PS3
  • firmware < 5.00 の PS4

Let's Encryptによると、新しいバージョンのiOSやMac OSは影響を受けないはずですが、リストで互換性があるとされている一部の新しいバージョンでも問題が発生しているようです。

今のところ、ユーザーがこの問題に対処できるかどうかは不明です。Firefoxは独自の証明書ストアを使用しているためFirefoxを使用して問題が回避できる可能性があると考えられます。

よかったらシェアしてね!
  • URLをコピーしました!
  • URLをコピーしました!
目次
閉じる